OpenCart-Hellas 

Η Ελληνική κοινότητα υποστήριξης του Opencart

Θέματα που αφορούν τη γενικότερη λειτουργία του Opencart.
#8059
Καλησπέρα σας,

Έχω προσθέσει στην εγγραφή να συμπληρώνει ο πελάτης την διεύθυνση του

Τον κώδικα και τα αρχεία τα πήρα από εδώ https://forum.opencart.com/viewtopic.php?t=204081

Καθώς κάνει την εγγραφή ο πελάτης βάζει κανονικά χωρίς κανένα πρόβλημα τον Νομό (zone), έπειτα όμως από την ενεργοποίηση του λογαριασμού του, εάν πάει στις διευθύνσεις δεν εμφανίζει τον νομό αλλά δεν βγαίνει και το dropdown για να επιλέξει και μου βγάζει τα παρακάτω error

Notice: Trying to access array offset on value of type bool in /home/bbshopgr/public_html/catalog/controller/startup/startup.php on line 166Notice: Trying to access array offset on value of type bool in /home/bbshopgr/public_html/catalog/controller/startup/startup.php on line 166

Έκδοση 3.0.3.6
Πρέπει να συνδεθείτε για να δείτε τα συνημμένα αρχεία σε αυτήν τη δημοσίευση.
#8060
Καλησπέρα,

Eλεγξε στη βάση, στον πίνακα address αν στη διεύθυνση του πελάτη καταγράφεται κάποιος αριθμός zone_id μεγαλύτερος από μηδέν και γενικά αν βλέπεις κάτι περίεργο στις καταχωρήσεις των στηλών. Αν χρησιμoποιείς custom fields δοκίμασε να διαγράψεις το περιεχόμενο της στήλης custom field στη βάση για τη διεύθυνση πελάτη που ελέγχεις.
#8061
Δεν βλέπω κάτι περίεργο στον πίνακα address, ο πελάτης είναι ο τελευταίος. Έσβησα και τα custom fields από τον πελάτη μέσα από τον πίνακα αλλά και πάλι τα ίδια

Επίσης έχω 2 custom field το ένα είναι το ΑΦΜ και το άλλο το όνομα εταιρίας αλλά και εκεί βλέπω πως είναι όλα οκ

Τέλος τα ενεργοποίησα και τα 2 και έκανα πάλι πελάτη αλλά και πάλι μου βγάζει τα ίδια error και δεν μου ανοίγει το dropdown να επιλέξω νομό, ενώ στην εγγραφή μ'αφήνει να το βάλω.

Εάν θέλετε να κάνετε login για να δείτε το πρόβλημα τα στοιχεία είναι:
[email protected]
123456
Πρέπει να συνδεθείτε για να δείτε τα συνημμένα αρχεία σε αυτήν τη δημοσίευση.
#8063
Κάτι που έχεις κάνει ή κάποια τροποποίηση που έχεις παράγει σφάλμα στο catalog/controller/startup/startup.php και κατ' επέκταση δημιουργεί πρόβλημα στις κλήσεις ajax. Δοκίμασε να απενεργοποιήσεις την εμφάνιση σφαλμάτων στο frontend για να δείς αν αυτό επιλύει το πρόβλημα με τις ζώνες και σε δεύτερο χρόνο λύνεις το θέμα του startup.php . Επίσης από τις ρυθμίσεις δοκίμασε να ορίσεις Χρήση Διεύθυνσης Φορολόγησης Καταστήματος και Χρήση Διεύθυνσης Φορολόγησης Πελάτη "Διεύθυνση Αποστολής".
#8064
Το πρόβλημα λύνεται όταν ορίζω Χρήση Διεύθυνσης Φορολόγησης Καταστήματος και Χρήση Διεύθυνσης Φορολόγησης Πελάτη "Κανένα".

Στα άλλα 2 συνεχίζει να μου το βγάζει

Το θέμα είναι πως όταν πάει να ολοκληρώσει παραγγελία ο πελάτης του έχει default να βάλει νέα διεύθυνση και όχι την διεύθυνση του

Καλησπέρα. Παρακαλώ μην ποστάρετε το ίδιο θέμα κα[…]

Καλησπέρα, Αν δεν διωρθώνεται δεν θα το έκανες ό[…]

https://image.opencart.com/cache/6368e1f818524-re[…]

Ως αποδεικτικό στοιχείο για το ποια επιχείρηση εμπ[…]

Πριν ζητήσετε βοήθεια στο φόρουμ, παρακαλούμε ελέγξτε αν υπάρχει έτοιμη λύση στο OpenCart Extension Marketplace!