OpenCart-Hellas 

Η Ελληνική κοινότητα υποστήριξης του Opencart

Δωρεάν επεκτάσεις, τροποποιήσεις (MODs, vQmods) από τα μέλη του forum.
#6052
Γνωρίζετε εαν λειτουργεί σωστά το Module αυτό σε 2.1.0.2?
https://www.opencart.com/index.php?rout ... iraeusBank

Στο module που έχω τώρα εγκατεστημένο έχω το παρακάτω πρόβλημα και λέω να δοκιμάσω αυτό αλλά βλέπω έχει να ενημερωθεί απο το 2017....

Κατόπιν διερεύνησης διαπιστώθηκε πως
χρησιμοποιείτε κάποιους μη αποδεκτούς
ειδικούς χαρακτήρες στις παραμέτρους
«PARAMBACKLINK» ή/και «PARAMETERS» που στέλνετε
στο paycenter.

Ως αποδεκτοί χαρακτήρες στα
συγκεκριμένα πεδία ορίζονται οι εξής,
βάσει των κανονισμών ασφαλείας κατά PCI :


· Λατινικοί χαρακτήρες (πεζοί και
κεφαλαίοι)

· Ελληνικοί χαρακτήρες (πεζοί και
κεφαλαίοι)

· Αριθμοί

· Το κενό (Space)

· Οι ειδικοί χαρακτήρες / : _ ( ) . , + -&=?


Παρακαλούμε για τη συμμόρφωσή σας με
τις παραπάνω οδηγίες έως την ΔΕΥΤΈΡΑ
13/01/2020 και την έγκαιρη ενημέρωση μας με
το πέρας των εργασιών σας, στην ηλ.
διεύθυνση [email protected].

Με εκτίμηση,

Merchant Acquiring & ePayments

ePOS Paycenter
ΓΝΩΣΤΟΠΟΙΗΣΗ-ΔΗΛΩΣΗ ΠΡΟΣ ΤΟΥΣ
ΠΑΡΑΛΗΠΤΕΣ
#8705
Βρήκες λύση με το πρόβλημά σου;

Μου το έβγαλε ξαφνικά σήμερα και δεν ξέρω από που προήλθε.

spyrosel έγραψε: 18 Νοέμ 2016, 16:46 Καλησπέρα!

Χρησιμοποιώ για πολύ καιρό το module και έπαιζε μια χαρά.

Ξαφνικά, χωρίς προφανή λόγο (δεν άλλαξα κάτι) μου βγάζει error "Fatal error: Can't use method return value in write context in /catalog/model/payment/GOP_PiraeusBankGr.php on line 252" μόλις φτάνει στο βήμα της πληρωμής. Έκανα update με την τελευταία version για το opencart που τρέχω (2.1.0.2) αλλά δεν άλλαξε κάτι.

Μπορεί κάποιος να με βοηθήσει; Ευχαριστώ εκ'των προτέρων!
#8706
Καλησπέρα,

Πες μας τι έκδοση OpenCart έχεις. Αν είναι 2.1.0.2, τρέχει με PHP έως 7.2.

Έλεγξε μήπως ο πάροχος σου άλλαξε την έκδοση PHP στον λογαριασμό σου.

Ενημερωτικά, σύντομα, μόλις χαλαρώσω λίγο από δουλειές θα ανεβάσω ως δωρεάν λήψη, την επέκταση Πειραιώς που παρέχουμε στους πελάτες μας με τρέχουσες προδιαγραφές και πολλές δυνατότητες.
#8707
Η έκδοση Opencart που τρέχω είναι η 2.3.0.2 και η έκδοση PHP είναι η 7.0.
Αναβαθμίστηκε ο server πριν λίγες ημέρες για να αναβαθμιστεί η MySQL και να καλύπτει το Joomla 5 και απο εκεί και μετά σταμάτησε να δουλεύει.
Μήπως πρέπει ενημερωθεί η τράπεζα για την αλλαγή του ip;
Κατά τ' άλλα δεν έχει αλλάξει τίποτα άλλο. Mόνο η έκδοση της MySQL και η IP.


Alexandra έγραψε: 08 Ιούλ 2024, 13:43 Καλησπέρα,

Πες μας τι έκδοση OpenCart έχεις. Αν είναι 2.1.0.2, τρέχει με PHP έως 7.2.

Έλεγξε μήπως ο πάροχος σου άλλαξε την έκδοση PHP στον λογαριασμό σου.

Ενημερωτικά, σύντομα, μόλις χαλαρώσω λίγο από δουλειές θα ανεβάσω ως δωρεάν λήψη, την επέκταση Πειραιώς που παρέχουμε στους πελάτες μας με τρέχουσες προδιαγραφές και πολλές δυνατότητες.
#8708
Αν άλλαξε η IP, εκεί οφείλεται το πρόβλημα και πρέπει να ενημερωθεί η τράπεζα.

Καλημέρα, Για κάτι απλό υπάρχουν μερικές έτοιμες […]

Καλημερα σας, Ευχαριστω πολυ για την απάντηση !

checkout - success

Ευχαριστώ πολυ!

Ευχαριστώ πολύ. Αν άλλαξε η IP, εκεί οφείλεται […]

Πριν ζητήσετε βοήθεια στο φόρουμ, παρακαλούμε ελέγξτε αν υπάρχει έτοιμη λύση στο OpenCart Extension Marketplace!